The Dink Network

Holes in the Story?

Forest of Doom

August 4th 2010, 10:53 PM
First, let me just say that I thoroughly enjoyed this d-mod. It was excellently made, with plenty of new graphics. I was able to finish the game, and thought it was well done. I plan to write a review for this dmod, but before I do, I have several questions.

First, I felt like either I was "missing" a lot of subplots and side-quests, or that I simply failed to find the stuff, despite searching through the whole map multiple times. Here are a couple of examples.

-Where, or is there, a key for that house up on the northwest corner of the map? If so, where can I find the key?
-I found the 3-liter barrel, but what about the 4-liter and the 5-liter barrel? These are supposed to go with the baker.
-Many of the houses I couldn't enter. Are they really just supposed to be decoration? Or are you supposed to be able to enter them somehow?
-I found the map for the northern part of the forest, however, is there a map for the southern part of the forest?
-I can't figure out the puzzle after you enter the secret in the waterfalls. Hints, please?
-The Pirates: Is there any way to actually beat the pirate in his little game? If so, how? I tried multiple times and could not do it. Also, what's the deal with the pirate and all his barrels? There is one barrel that I cannot smash.

Bugs (or perceived bugs):
-After you kill a normal enemy (like the spiders), they never respawn or reappear. Is this intentional? I hope not, because I would like to be able to go back and kill them all again for the gold. Nor would it truly be a forest of doom is Dink kills off all the bad guys. This is the only major flaw I found.

-Is there anyway to make this file size smaller or compress it? Often times, I would walk onto a screen and it would take some time to load. I realize you got a lot of scripts going on, but I don't think that it should take that long for the next screen to load, even if that screen has a special script attached to it.

Again, it was a great dmod. Thanks!
August 4th 2010, 10:54 PM
The Dark Lord of the DN. 
This shoulda been the review.

EDIT: Install Aural+. Screen loading-time is caused mostly by larger MIDIs. If that's the case installing Aural+ will help them load a hella a lot faster.
August 5th 2010, 04:13 PM
You FINISHED this??? How do you get past the 'parole' guy?
To answer at least a couple of your queries - in the Northern section, way off to the right is a place with a bunch of red-headed vikings guarding a cave - in the cave is a chest with the key in it - for all the good that does you as there's nothing in the house but a dead goblin who doesn't have the waraxe.
The pirate puzzle CAN be done but it's far from easy and took me multiple tries - what you are looking to get is 4 on your last try which leaves him 1. I don't know if it was just luck, but I beat him 2ce. I had to because the first time I had broken all the barrels and found out he charged an exorbitant price for the one lonely barrel (5K) as opposed to the 500 golds if you don't break all the barrels. And his barrel is the one you need for the mixing station - be cautious at the station, talk about the barrels before you set them down or you get a sort of freeze that causes the 'mixing' to happen without a list of how you want to mix. I got frozen many, many times all through the game, but I agree it's a lotta fun. Oh, and is there a brass whistle somewhere for that last dragon? Which I can't kill.....
August 6th 2010, 02:31 AM
Peasant Male Austria
Think positiv. Say NO. 
Hi Teenager,
I am glad that you liked my game. Here are some explanations/hints/answers

-Where, or is there, a key for that house up on the northwest corner of the map? If so, where can I find the key?
There is a key to the house (otherwise you will not be able to finish the game without cheating). There are two archers (where the engine most ofte kills the calling script and you get stuck - I uploaded a patch but the board didn't released it yet)
-I found the 3-liter barrel, but what about the 4-liter and the 5-liter barrel?
There is a 5-liter barrel and you are supposed to mix the 4 liters on the mix table
Many of the houses I couldn't enterThey are just decoration. It is my first DMod and I was happy when I finished it. So I had no nerve to make a lot of houses with may be story too.
-I found the mapYes there are maps for both parts. No really helpful (in my opinion) but still there are.
-I can't figure out the puzzle after you enter the secret in the waterfallsstart in the middle and it becomes easy
-The Pirates: Is there any way to actually beat the pirate in his little game?
This is a mathematical thing. Try to think how many things can be removed for sure in each round by both persons. Then it is very easy and has nothing to to with luck.

The house is very important because there you will find the head of the hammer.

I hate it when enemys reappear and you are able to increase your gold and strength by will. This is against the story to get too strong too early.

The problem with the waiting time: Because I have so many new enemies I had to workaround the limitations of the dink engine. In the engine you are allowed to have ~1000 slots. In each slot you can put 50 pictures. For an enemy you need 10 slots. Otherwise the engine is not able to bring the proper picture for the current direction. Well 3 times 10 slots because you have walking, attacking and dying. Most of the slots are already filled so in fact you only have ~140 slots free.
I use around 30 new enemies -> 30*30=900 slots
So in each screen the lg.c script loads the graphic it needs for the enemy on demand. And sorry, but this takes the time.

This workaround has another ugly side effect: The engine has a bug when it loads graphic during the game. Even when you put the graphics all into the same 30 slots all the time you will end up in a situation the static graphic like bushes bacome bats, stones, or whatever. In cases like this save the game, quit and restart. Sorry for it.

I tried to compress the graphics but I failed. I suppose this is due to the issue that I am not reducing the pictures to the Dink palette. So when I use the compressed pictures you only see black rectangles on the screen

To ninkasi:
brass whistle Yes there is one, but...
as mentioned earlier I filed a patch and you need it when you use the whistle - by the way this is a flute not a whistle (anyway). If you don't have the patch you will get hurt even when the little dragon is dead.

Reason for both 'bugs' (as far as I know): I call two times the sp_script function for one sprite. The second call kills the first calling script - with effects like 'freezeing everything' 'hurting Dink without reason and cause'

All my puzzles are logical one. So the parole guy is not as hard as you think - a hint that you as well can found in the game (at the furious goblins in the well) is: The parole has nothing to to with mathematic.
August 7th 2010, 09:32 AM
Ninkasi, in order to get past the Parole guy, walk onto the screen behind the trees. Listen awhile and get some hints on how the numbers work. The right answer is always smaller than the number he spits out.

Actually, I found the head of the hammer along with the handle of the hammer at the same place (where you strike the rock and they both appear behind the tree). This sounds like it must be an error. I was also able to hit the rock multiple times and the both parts of the hammer appeared multiple times. I could also pick them up and have multiple hammers in my back-pack. This was the only reason why I could finish the game, and did not need the key to the house.

Now that you mention it, the game the DOES freeze everytime where the two archers are located.

August 8th 2010, 08:28 AM
Peasant Male Austria
Think positiv. Say NO. 
Hi teenager,
wow that's really interesting. A stone where you get both parts of the hammer?!?!?
As far as I know I did not code such a thing
Could you please tell me where you found such a stone? You can send me also the information per EMail. This might be faster.

Thank's for the info.
August 9th 2010, 04:41 PM
Ok, I sent you a mail. Check your inbox.
August 10th 2010, 02:33 AM
Peasant Male Austria
Think positiv. Say NO. 
Hi Teenager,
I didn't believe it - but I found the script and the stone.

Grrrrrrrrrr. I have long forgotten about this first test script.

You are right, this is an error. Please remove the script stone.c from the story directory and everything is back to normal.
August 10th 2010, 04:20 AM
Peasant Male Finland bloop
"I'd like to be a tree..." 
No, I shall not.
August 10th 2010, 05:26 AM
Peasant Male Austria
Think positiv. Say NO. 
at least you should enhance the current code in stone.c with:
void hit()
"I am too lazy, unwilling, non experienced: I need to cheat. I can't wait for it. Do it."
"No I take the burden of the real adventurer"
if(&result == 1)
...current hit code...

That would be fair, wouldn't it?
August 20th 2010, 12:35 PM
I would be curious to know when the patch will be available, so that I can find the key properly so that the screen doesn't lock up where the two archers are located. I would also be curious to know if you were going to upload a newer version that fixes some of the other bugs?

Take care.