The Dink Network

Bug report

Cloud Castle 2: Scarab

June 14th 2007, 08:37 PM
I'm playing CC2 again and I'm getting some weird bugs.

Bug 1: I can't get rid of the homing crystal! Every time I walk onto a screen with a save machine (worked out after a lot of confused testing!) it reappears in my inventory. I've chucked the blasted thing away so many times...
It makes a handy weapon actually. Let out some frustration by bursting scarabs with it

Bug 2: I'm having the same problem as here. Details: When I get to Alessa's village I have 45 (I think) brown mushrooms to start with. If I pick up a brown or red spotted mushroom first thing then Thargo doesn't appear. If I speak to Thargo first he asks for a green mushroom as normal, but I can't pick up the green mushroom and if I speak to Thargo again I give him brown mushrooms (even though I haven't touched any) and it carries on from there. If I pick up brown ones I have 46, 47, 48, etc.
It might be something to do with replaying the game 'cos I had no problems the first time.
June 15th 2007, 12:34 AM
Noble He/Him United States
Super Sexy Tal Pal 
The homing crystal issue has been there since the dawn of time. I think I reported that both when I beta tested it the first time and then when I retested it worth a flip.
June 15th 2007, 02:33 AM
Peasant He/Him Finland bloop
A Disembodied Sod 
I suppose the crystal should be like that.
June 15th 2007, 10:41 AM
Noble He/Him United Kingdom
The homing crystal issue is not a bug.

The Mushroom thing on the other hand, is a bug. I'll have a look at it in a week or so, unless Arik has already fixed it...
June 16th 2007, 07:36 PM
The homing crystal is not a bug? You mean it is deliberate? What's the reason for that, story-wise?
June 17th 2007, 08:20 AM
Peasant He/Him Belgium
I also had the Alessa bug when I played it yesterday. I seemed to be able to fix that by loading a different savegame. The &temphold6 variable (or something) seems to be used in other places in the game. When you backtrack while those variables are in use and activate Alessa's Dream world at that time it won't allow you to pick up the mushroom.
June 17th 2007, 04:55 PM
Peasant He/Him
Yeah, Alessa's dreamworld is annoyingly bugged. I've fixed it for the new version, but the new version isn't entirely finished yet. Sorry about that.

The homing crystal isn't a bug, it's a joke. It's, like, a homing crystal I was going to put some plot/gameplay stuff in there for it but I, uh, didn't. Maybe something'll end up in CC3.
July 22nd 2011, 08:48 AM
Ghost They/Them
Ive just escaped from the dungeon with Alessa and Fabian, i get to the cut scene where Churnblade is talking to the younger dink, the scene finishes and Churnblade turns into the scarabs. I kill these and pick up the scroll. I get asked who wants to join the party back to the village. Whoever i pick the game crashes and have no other way of passing this screen.

Any help would be appreciated.