The Dink Network

bug report: memory problem with freedink on linux

Day of the Carcass

January 13th 2010, 10:33 AM
peasantm.gif
hoki
Peasant Male
 
Hello

i wanted to give this dmod a try. I am running a Pentium III, 800 MHz with 512 MB RAM and 512 MB swap on Ubuntu Linux 8.04. No problems with the original Dink game or other dmods so far.

I installed the dmod and watched the intro just to the sequence when they're 7 years older, something with "an ordinary day...". After this the game quits with an errorcode 1.

Starting the game from the console with
freedink -g ~/dmods/DotC

gives the following error messages.
[ERROR] [DinkC] sp_editor_num: invalid sprite 0
[FATAL] sp_custom: Not enough memory to add value 'clipme'

Hope that helps
Hoki
January 13th 2010, 12:20 PM
dinkdead.gif
Don't know about this error but make sure you're using the latest version, there's been a couple of problems before that have been fixed by this.

If you don't already have it the newest version is from www.freedink.org, the one from Ubuntu is a bit old I think.
January 13th 2010, 01:10 PM
slimeg.gif
metatarasal
Bard Male Netherlands
I object 
The one from the Ubuntu software center in 9.10 is the one causing problems. I think the one in 9.4 hasn't got that specific bug (filename thingie). This sounds like a problem with the handling of editor nums.

Can you tell us what version of Freedink you are using Hoki?
January 14th 2010, 01:51 AM
fairy.gif
Someone
Peasant Male Australia
 
I get it too with 1.08.20090918, Ubuntu 9.10, a gig of RAM and a couple gigs or so of swap. Same [FATAL] line & same place. I don't get the [ERROR] line (or didn't find it, it wasn't directly above anyway).

I poked around and it crashes with this line in HealthRed.c:

sp_custom("clipme",&current_sprite,180);

It looks to be the first call of sp_custom.

I tried to run mousedink to see if sp_custom was broken and it crashes now too (immediately upon pressing the start button, apparently on the first sp_custom), with the same error:

[FATAL] sp_custom: Not enough memory to add value 'text'
[info ] Shutting down CD stuff.
[debug] Killed script c-load. (num 1)
[debug] Kill_all_callbacks just killed 1 for script 2
[debug] Killed script c-main. (num 2)
[debug] Killed script pushable. (num 3)
[debug] Killed script c-main. (num 4)
[debug] Killed script c-cd. (num 5)

So I think sp_custom is broken somehow..
February 21st 2010, 01:27 PM
farmer.gif
Beuc
Peasant Male France
 
I just fixed it, can you try this snapshot and confirm?
http://www.freedink.org/get-snapshots
deb http://www.freedink.org/snapshots/debian/ ./

(and send me a mail next time? )
February 27th 2010, 04:36 AM
fairy.gif
Someone
Peasant Male Australia
 
yup it seems to be fixed
April 1st 2011, 04:56 PM
pq_water.gif
hendy
Peasant Female United States
 
I would like to play this DMOD, but I have the same problem - after the intro on Day of the Carcass, it quits and says

Dink Smallwood failed! Error code 1.

I don't know how you guys fixed it, but can you tell me what to do so I can play it?