The Dink Network

Reply to FreeDink 109.6 sound issue under Windows 10/11?...

If you don't have an account, just leave the password field blank.
Username:
Password:
Subject:
Antispam: Enter Dink Smallwood's last name (surname) below.
Formatting: :) :( ;( :P ;) :D >( : :s :O evil cat blood
Bold font Italic font hyperlink Code tags
Message:
 
 
August 19th, 03:59 AM
goblins.gif
drone1400
Peasant Male Romania
C# nerd 
I have had this issue with FreeDink, but I never really mentioned it before since I had a workaround. The issue is, when I start FreeDink, it plays MIDIs just fine, but it does not play WAV files. So I get no sound effects like menu navigation, punching, etc.

My solution to this under Windows 10, is to change my Spatial Sound settings from Off to Windows Sonic for Headphones and then back to Off . For some reason this fixes it... In windows 10 there are two ways to do this:
1. right click sound icon on the task bar -> Spatial Sound -> Off / Windows Sonic for Headphones
2. type Sound Settings in the windows search, then on the sound settings page, under the heading Output go to Device Properties; on this new page you should see a Spatial Sound combobox which you would have to switch from Off to Windows Sonic for Headphones then Off again

Under Windows 11, things are more tricky. RobJ was telling me he was having the same issue (which prompted me to make this thread too). Apparently, for him changing sound settings in Windows 11 didn't work except for a specific pair of headphones. Basically, from what he said, he was using multiple sound outputs and only one of them worked properly:
- bluetooth headphones - he could not change the spatial sound settings
- 3.5mm jack speakers - he could change the spatial sound settings but said it didn't fix it
- USB headphones - he could change the spatial sound settings and it worked!

Apparently Windows 11 has some known issue with spatial sound and bluetooth headphones... RobJ found this posted on reddit about it:
>"If you're on windows 10, go inside the regular windows settings, then audio, find your headset and click device properties. Enable it from there, it will work. If you're on windows 11 you're shit out of luck, this workaround doesn't work anymore. The only thing that can make it work is uninstalling ghub, uninstalling DTS, rebooting, install and enable DTS, keep the app open and install ghub. If sound still works after rebooting you're good to go, but you'll have to open the DTS app everytime for the first time you switch to/use the headset."


PS: When I first discovered this myself, it was kind of by accident since at the time I was having this issue for FreeDink other games, and playing videos in Discord too! I'm not sure what led me to mess with spatial sound settings, but that fixed it and I figured it was just some weird issue with the sound card I'm using. I've long since reinstalled Windows and now only FreeDink does this. I have no idea wtf is going on to cause it to malfunction in this way. I imagine it's just Windows being its wonderful old self