The Dink Network

Stuck in Cloud Castle 2

Cloud Castle 2: Scarab

July 25th 2005, 08:47 PM
duckdie.gif
I'm playing Cloud Castle 2 and I'm stuck in the part where the librarian hits you on the head and puts you in jail. I've gotten out and looked around, and have 1 of the tear gems, but can't find the other. I'm assuming it has to do with the fountain riddle, but I can't get it to work... Anyone know what to do?
July 25th 2005, 09:43 PM
knight.gif
Vortex
Peasant Male United States
It rubs the lotion on its skin... 
Take your comp and rip out the hard-drive. Then precede to hock the biggest luggy ever right into it. If you won't to completely fix it you may wont to wrap it in electrical tape also. Then jam it back in and hit the on button... Next time you play the game, it should be fixed...

Seriously dont do that... I dont want to be responcible... Do we have some sort of "TDN takes no respomncibility for the help or information given within"?

July 26th 2005, 05:35 AM
duckdie.gif
You have to hit all the dragon statues in this order : The statue that says 'Y' when you talk to to it, the statue that says 'R' when you talk to it, the statue that says 'C' when you talk to it ( remember the riddle? SEA = C ), and finally the last dragon statue, the one that says 'X' when you talk to it. Go back to the fountain and look at the spark to find the second ( and last ) tear gem.
November 12th 2005, 12:06 PM
anon.gif
Bruno
Ghost
 
Hi!

I hit in the dragons (Y,R,C and X, in this order), but there is nothing on the fountain. Other detail:When I hit the dragons, there is a different noise, but when I hit the dragon Y, this noise doesnt appear.
March 16th 2007, 11:09 PM
duckdie.gif
Has anyone encountered and solved this problem? I have it too...
March 17th 2007, 06:42 PM
duckdie.gif
Fixed. Reverted to Dink 1.08 original and tried it then.