The Dink Network

Reply to Re: Zippo does not work?

If you don't have an account, just leave the password field blank.
Antispam: Enter Dink Smallwood's last name (surname) below.
Formatting: :) :( ;( :P ;) :D >( : :s :O evil cat blood
Bold font Italic font hyperlink Code tags
October 29th 2019, 02:33 PM
Peasant He/Him United States bloop rumble
2nd generation. No easy way to be free. 
Oops again.

Okay, so the bz2 file you "sent" me had these 8 save.dat files in it.
login@system:~/Downloads/Anglers_Saves$ ls -lt
total 2560
-rw-r--r-- 1 login login 326048 Oct 28 07:49 save4.dat
-rw-r--r-- 1 login login 326048 Oct 25 05:45 save6.dat
-rw-r--r-- 1 login login 326048 Oct 25 05:45 save5.dat
-rw-r--r-- 1 login login 326048 Oct 17 05:12 save7.dat
-rw-r--r-- 1 login login 326048 Oct 16 07:07 save9.dat
-rw-r--r-- 1 login login 326048 Oct  8 05:07 save1.dat
-rw-r--r-- 1 login login 326048 Sep 30 10:06 save8.dat
-rw-r--r-- 1 login login 326048 Sep 30 09:48 save10.dat

The save4.dat file had the most recent date on it of the 8 you sent me and when I fired up the before dmod, it showed that the timestamp for save #4 was the one that had the most time (11:42) in it. I loaded it, and found that it was the one with Dink outside the pyramid. Using that save file, I tried many variations on how Dink could use the zippo and enter the pyramid. The only one that seemed to reproduce your problem would be lighting the lighter (whether outside or inside the pyramid) and then selecting another magic item to use. This extinguishes the lighter. Is that what you are doing? If so, then the "solution" is just to keep the lighter in use.

If that is not what you are doing that is a bit different compared to how others might enter the pyramid, then I MAY be able to patch the armzip.c file to prevent this error. When I light the lighter, I see this error (sent to stdout apparently).

[ERROR] [DinkC] armzip:44:[var_equals]: unknown var &active_when_started

You can get the above error output (due to my not removing a variable assignment to a variable that is no longer declared and no longer really used) when you start dfarc from a shell window before you launch the before dmod. When I see it, nothing happens to the game as far as I can tell. Maybe this error in your system is causing armzip.c to crash? If so, then it is still possible that the "animation" would change to show the lit lighter, but you would never hear:
(1) the "magic sound" of the zippo lighter starting up, (which is #43 SECRET.WAV; found in the original Dink Sound directory). This uses the same wave file that is heard when screenlock is turned off.
(2) the sound of the lighter burning (which is #23 FIRE.WAV; found in the original Dink Sound directory). This uses the same wave file that fireplaces use in the game.

If you don't hear both sounds when you try to ignite the lighter, then MAYBE removing the line causing the error in armzip.c would provide the solution to your situation.

To test out a theory, I tried aborting the armzip.c file right after the faulty &active_when_started line. As expected, the "animation" replacing the unlit lighter with the lit one took place. In addition to not hearing the two sounds I mentioned above, Dink also remained frozen in place after trying to light the lighter, since the armzip.c file never got to the "unfreeze(1);" statement. Is this what you are experiencing?

If I'm right about the above error crashing armzip.c for you, then you can fix armzip.c by removing the "&active_when_started = 0;" statement on line 44 of armzip.c (assuming you are comfortable using your favorite text editor to do so). Either way, I'll make this change for the next release of the Before... dmod.

I look forward to hearing how things work out for you and whether or not we are getting close to a solution.