The Dink Network

stuck in goblin village

Scourger (The)

November 14th 2009, 10:38 PM
anon.gif
kpetermn
Ghost
 
if i talk to anyone in a house i can not leave the door (outside the house)

here is the error if it helps.
This is from freedink on linux

[info ] Loading script STORY/R3-LANGUAGE.C.. (slot 3)
[debug] Reading from disk...
[debug] Script r3-language is entered at 1:16 (offset 16).
[debug] Compared 72 to 72
[debug] If returned true
[debug] Callback added to 1.
[debug] giving script the boot
[debug] GFX screen = 307200
[debug] GFX buf = 921600
[debug] GFX bmp = 5935912
[debug] GFX tiles = 6800000
[debug] GFX total = 13964712 (+ ~150kB fonts)
[debug] Sounds = 1578936
[debug] Script r3-language is entered at 6:9 (offset 63).
[ERROR] [DinkC] r3-language:8: fade_down() called during fade_up(), ignoring fade_down()
[debug] giving script the boot
[debug] Called script 3 from callback 1.
November 16th 2009, 04:39 PM
slimeg.gif
metatarasal
Bard Male Netherlands
I object 
Sounds like a problem with FreeDink rather than with the DMOD.

From your errorreport I think this is the problem:

The script r3-language.c is called when the screen is entered. Then the screen is still fading up, so FreeDink ignores the request of r3-language to fade down. Seemingly it ignores the rest of the script from there. Normally Dink doesn't ignore the fade down command when loading the screen.

So an errorreport for freedink it is then I suppose. I can't replicate it myself though as I don't have freedink.

If you just want to continue the DMOD you can edit the script in question. There should be this command:
wait(1);

Change the 1 to something larger, 1000 will probably do the trick:
wait(1000);


This will make the game pause for a second, so don't move when you enter the screen!
November 25th 2012, 01:40 PM
anon.gif
SebastianT
Ghost
 
Thank you for your workaround. For my system...

DFArc 3.4, Nov 6 2009
FreeDink v1.08
Ubuntu 10.04 LTS
Dell D630 / 2.2GHz Core2 Duo / 2Gb RAM

this worked:

void main(void)
{
wait(100);
if (&story == 72)
{


I tried 1 and 10, but they were apparently not long enough.