The Dink Network

Cloud Castle 2 game crash error (Side-quest SPOILERS)

Cloud Castle 2: Scarab

May 22nd 2019, 09:16 AM
Hello. I am new around here, but I will go straight into the topic because this crash has been bugging me for a long time now even though it is for an "optional quest" it is still the form I like it most.

While on oasis and in the quest to find shapeshifter's daughter, after you have found her and suggested her to reconcile, after the scene when they all return back to the girls mother, after she says: "Mother!" the game crashes after an error message. I followed the instructions and I found this:

"ERROR: Tried to read script 6"

Unfortunately: I've got no clue for how to fix this This is the only choice, that sets in motion the events, where you can get the most XP and most gold out of the quest (plus: The moment when you'll find out that the mother is actually a Slayer.) I would greatly appreciate it, if someone could look into this error and/or fix it.

Also I've got another strange bug in this game: When you go inside the fallen part of the Cloud Castle and into the upstairs, even when you do not have Alice with you, the game will initiate the events where (if you wait long enough) you'll begin the side-quest event in which Dink will end up inside the Alice's past (apparently) and well... If you have played through this side-quest you know what I talk about. Another problem here is this: In whichever way you complete this side-quest as you return, Monkeynuts is still at the upstairs where you appear after defeating that giant pig boss and you will be at risk of initiating the same side-quest events again and this time: You will not be able to even start it for the second time as you cannot even move.

And one more thing: I have never had these problems before on Dink Smallwood HD. Some years ago it still worked fine with both cases but now: It just simply doesn't.
May 22nd 2019, 10:05 AM
Peasant Male Equatorial Guinea xbox steam duck bloop
can't flim flam the glim glam 
ah, yep. you're on dink hd. never use dink hd.

@redink1 - you should really pull dink hd from this site so people stop getting the wrong impressions/loads of issues with the game or dmods that are entirely dinkhd's fault.
May 22nd 2019, 10:53 AM
Any ideas what to do? I can't make the "original Dink Smallwood" work on my PC because I have Windows 10 its about bit-8 and 640 x 480 not being supported.
May 22nd 2019, 12:32 PM
Bard Male Finland bloop
cigarette bonca 
First, you should download the original game (this is so that you get all the game files). Then, download FreeDink, and extract freedink.exe in the same folder as the original game. (And everything else of course if you want to. I think there's a Finnish translation of the game ='P)

Then in DFARc, go to the options and select freedink.exe as the game program rather than dink.exe.

FreeDink's great, it's virtually identical to the original game, except it's up-to-date with modern systems.
May 22nd 2019, 12:51 PM
I got a new problem: When I attempt to launch Dink Smallwood, despite the fact I did just as you told me to do, I get this error message:

Could not open font 'LiberationSans-Regular.ttf'. tried: - loading from './freedink' [build prefix]
May 22nd 2019, 01:16 PM
Ah, I figured out the problem: I forgot to extract "freedink" file to the "Dink Smallwood" folder. With that and freedink.exe as well as freedinkedit.exe in places, I think it should work now.

Also: I personally do not care about Finnish in games because to be honest: I am more used to English myself, partly because Finnish language especially in some game manuals are often misdirecting and vague while English is usually more specific and accurate. In any case: Which file should I move the LC_MESSAGES files?