The Dink Network

Trapped in locked screen

Cloud Castle 2: Scarab

November 21st 2011, 06:36 PM
I'm playing Dink Smallwood HD v 1.4.7 Build 1 Script version: 1.09 on a Macbook.
On the Cloud Castle 2 DMOD v1.0, I'm trapped in a locked screen.

I've just killed the boss Kurt and picked up his sword. The guardian lamps went out, but I the screen is still in locked mode, so I can't exit the screen to continue my adventures.

Is there a known fix for this or an easy cheat to unlock the screen in the Mac version of Dink? I can only find unlock cheats for PC.

November 21st 2011, 07:22 PM
The Dark Lord of the DN. 
Could be HD since it is horrifically bugged, but I had this bug before HD even came out. O_o

I forgot even what I did to fix it.
November 22nd 2011, 02:38 AM
I think the unlock cheats would probably work anyway. I think I had this problem as well; tried again and it didn't happen. It might have to do with the moment of killing him, in particular if there are any active fire fountains or other enemy sprites on screen. Haven't actually checked it though. If you just kill him again (maybe several times) it should eventually work, I think.
November 22nd 2011, 05:29 AM
Peasant Male Sweden steam
Cheats should work for all dink versions as they are just plain c scripts you install in the dmods directory, on mac if think it is Library->Application support -> Dink HD.

I wouldn't recommend using unlock cheat though, as everything still might not work in the future (If the screen didn't unlock maybe it missed changing variables and things too) as said earlier I think it's better just to load a save and try again.
November 22nd 2011, 10:59 AM
Thanks all. I've tried returning to an old save and killing him again, but I'm still locked in. I'm a bit confused on where the dmods directory is and where to put the cheat key so that it functions properly. The 2 dmods I have (Cloudcastle 2 and The Savebot Massacre) came with the game when I originally downloaded it. Forgive me, for I am not a script writer. Here are my options.

If I go to Applications>Dink Smallwood HD>Contents, the possible folders are:

Applications>Dink Smallwood HD>Contents>Resources is split into:

with Applications>Dink Smallwood HD>Contents>Resources>dink split into:

and Applications>Dink Smallwood HD>Contents>Resources>interface split into:
November 22nd 2011, 02:42 PM
Peasant Male
I can take a look at the save game if you are happy to email it over to me ( I haven't got the same platform, but if people have experienced it in earlier versions I might be able to figure it out. Does the game give you the sword, and is there some talking after the lights go out? Also, which NPC do you have with you?