The Dink Network

Reply to Re: End of an Era?

If you don't have an account, just leave the password field blank.
Username:
Password:
Subject:
Antispam: Enter Dink Smallwood's last name (surname) below.
Formatting: :) :( ;( :P ;) :D >( : :s :O evil cat blood
Bold font Italic font hyperlink Code tags
Message:
 
 
June 5th, 11:39 AM
spike.gif
SlipDink
Peasant Male United States bloop
2nd generation. No easy way to be free. 
In your example with running your dmod, "a little adventure" -

That warning message is only scripted to display if the script detects your running in 1.07 mode. Not sure why your Dmod is detecting it that way.

Me neither.

That should not be possible, I just checked the script and even tested it with another random dmod.. Im on Windows though, but that shouldnt matter - I tested in freedink 108.4, which by the looks of it is the same one you were using for "a little adventure".

The scenario you reported in testing my demo.. that's the intended behaviour.

Oh, okay.

And I'm assuming you tested with the same version as with your dmod "a little adventure?".

You assume correctly.

If that's the case it Seems your Dmod is returning the wrong value in the same situation, so there's some sort of issue specifically running it with your dmod. Which is odd.. I tested this with a few dmods on my end in windows and it worked OK.

Hmmm. This sounds like it will be interesting to debug.

Also in all these examples when you say you see the version text "at the bottom of a black screen", what do you mean..

Well, for "A Little Adventure", we first see [SCREEN #1] my loading screen (tiles/splash.bmp), displayed while loading takes place. Then we see a black screen [SCREEN #2] that acts as a backdrop for the confusing message/menu about 1.08. Then, after I select Continue from your menu, my dmod goes on to display my own message on a black screen [SCREEN #3] (from smplevchk.c [Simple Version Check]; code I used from your 1.0 version checker that I customized for my purposes months ago). This code displays the message "`%This LOOKS LIKE a compatible (v1.08?) version of Dink Smallwood." and `%(press any key).".

These two screens [#2, and #3] that follow the splash screen, both show the "V1.08 FreeDink" message at the bottom of them.

Then the next screen [SCREEN #4] is my rather standard title screen, along with the usual [Start], [Continue], [Cancel] buttons, etc.

I installed your 2.0 version checker as instructed into my "A Little Adventure" dmod, figuring that I could decide whether to use it instead of my smplvchk.c script, or incorporate parts of it into my smplvchk.c script or not use it at all. For now, I'll leave it in place to help us understand what might be going on.

As for the times I ran your 2.0 and 2.01 demo/dmod, both of these displayed your version checker title screen, (including the [Start], [Continue], [Cancel] buttons) upon startup. The difference was that your 2.0 code displayed that "You are running an outdated version of FreeDink... Exit" message and your 2.01 code displayed no such message, making the use of the [Start], [Continue], [Cancel] buttons possible.


It should be displaying on the title screen just as the normal hard coded version text did.. Which is also working for me on Windows.. I hope Linux isn't being weird.

Hmmm. I cannot say what the cause of the anomalies we are seeing could be as of yet.

Are you able to send your dmod to me so I can debug it and see what the issue is

Yes, I will trim down a subset of the dmod that reproduces the error and make it available on my google drive. I would prefer to only send a subset because I'm kind of excited about how this dmod is a bit different and I don't want anyone to see any secrets of the plot or mapping quite yet. I'll edit this message later once I have done that, so the URL will be available for your use.

EDIT: ========================================================

I have packed up a sample dmod or ("SAMPLE for VERSION TEST A Little Adventure v0.91" as it says in dmod.diz) for your testing purposes. It demonstrates the issues mentioned above and can start the first "intro1.c" script that introduces the player to the "A Little Adventure" dmod.

This is the URL that can allow you to download it for your use: [ https://drive.google.com/file/d/11_7xmg7SzujtdanUj3TIUaG2rZv02Qa8/view?usp=sharing ].

Good Luck!