The Dink Network

Few problems related to compiling the FreeDink


July 17th 2014, 05:35 AM
I have a few problems related to compiling the FreeDink, I am currently using Ubuntu 14.04.

1.When following the instructions i couldn't perform the sh bootstrap saying that it does not exist.
2. After configuring the file and trying to run a make command. It displays that the makefile does not exist, i can't even perform the "make install" as well.
3.Do i have copy freedink-date to the freedink source code as well. along with the original files from the Dink smallwood 1.08? I want to play without the custom sounds as i've heard that the FreeDink uses different ones due to the copyright reasons.
July 17th 2014, 04:52 PM
It's been a while since i compiled freedink from source code in linux, all i can answer for now is number 3:
As far as i can remember, freedink-data contains the images (which i think they don't have copyright) and the sounds you mention. I once tried copying the original sound files to the data folder and it worked out well, so you could try that once the compilation problems are solved...

Hope Beuc or someone else can come around for a bit and answer the rest...
July 18th 2014, 05:25 AM
Peasant Male France

First, I'm not sure why you want to recompile FreeDink, if you just want to use the data from the original Dink, just edit "Override Dink Smallwood directory" in DFArc

Also you're posting in the "freedink-data" file discussion, so I'm not sure if you're working with "freedink" (which can be compiled) or "freedink-data" (which is just the game data and does not need compilation).
So let us know what version of FreeDink you are trying to compile.

If you're compiling 108.2, just follow the instructions in the "BUILD" file.
Should there be an issue, please copy/paste your full terminal output to e.g. so we can see what's wrong.

If you're compiling the latest version from Git - well don't, it's a development version that is not stable yet.

Good luck
July 20th 2014, 10:29 PM
I just tried compiling git's version in an old linux mint, and i got stuck at the step where you have to do:
apt-get install gnulib
apt-get install autoconf automake pkg-config help2man gettext autopoint rsync

because the repositories file got misconfigured, and then
sh bootstrap

failed because of that. Could it be a related problem?
July 22nd 2014, 05:02 AM
Peasant Male France

It is not possible to help you if you don't give more information.

Please re-read my previous answer and provide the information I requested, in particular why you want to compile, what FreeDink version you are compiling, and what actual error messages you get.
August 12th 2014, 06:24 PM
Hi Beuc,
Sorry for not posting back sooner. Please note i'm not the thread's owner. I just installed ubuntu 14.04 and i got a different error than the one the thread's owner mentions. For me, the compilation process goes fine until the ./configure step.
Answering your questions:

why you want to compile
i just wanted to test out what the thread owner tried to do, and also to get the latest version of the program

what FreeDink version you are compiling
i'm not sure, i got it from the git repository mentioned in the BUILD file: git://

what actual error messages you get
For me, all goes fine until the ./configure step, which throws these errors:
Errors and warnings recap:
* You need to install the SDL libraries:
Requested 'SDL2_image > 2.0.0' but version of SDL2_image is 2.0.0
Requested 'SDL2_mixer > 2.0.0' but version of SDL2_mixer is 2.0.0
Requested 'SDL2_ttf > 2.0.12' but version of SDL2_ttf is 2.0.12
No package 'SDL2_gfx' found
* You need to install the 'check' testing framework:
No package 'check' found

There are errors - stopping. Please check the reports above.
If dependencies (such as SDL_gfx) are missing,
please check BUILD for distro package names.

Thanks for your help
August 12th 2014, 11:39 PM
Peasant Australia steam
I've come to get my meat 
I'm no expert but that looks like you've either got the wrong packages installed or has a problem in it. Just having a look at the repo now, it looks like line 140 of may be missing a few >= signs which would cause this error because there aren't newer versions of those frameworks yet.
August 13th 2014, 04:43 AM
Peasant Male France

As I mentioned:
> If you're compiling the latest version from Git - well don't, it's a development version that is not stable yet.

More precisely it's in the middle of large changes and uses very recent technologies not stable in Ubuntu yet.

If you want to contribute to the FreeDink development that's a different story and we can work this out. Otherwise don't bother attempting to compile an in-progress version
August 13th 2014, 01:39 PM
Ok, thank you for your help. And now that you mentioned it, yes i would like to contribute to Freedink in some way, if you'd please let me... i'm quite a newbie programmer but i'm sure i can help with testing, translating or developing a small module for the program
How can i further contact you?